Archive for the ‘Cisco General’ Category

Show isdn service

Posted: September 18, 2006 by sankar in Cisco General

To find out which channels are in service, which are out of service, use command,

sh isdn service. Here is a sample output from a Cisco IOS router.

 BR1#sh isdn service
PRI Channel Statistics:

%Q.931 is backhauled to CCM MANAGER 0x0003 on DSL 0. Layer 3 output may not appl
y

ISDN Se0/0/1:23, Channel [1-24]
  Configured Isdn Interface (dsl) 0
   Channel State (0=Idle 1=Proposed 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)
    Channel :  1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4
    State   :  0 0 0 3 3 3 3 3 3 3 3 3 3 3 3 3 3 3 3 3 3 3 3 3
   Service State (0=Inservice 1=Maint 2=Outofservice 8=MaintPend 9=OOSPend)
    Channel :  1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4
    State   :  0 0 0 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2
BR1#

How to hide users in Corporate Directory?

Posted: September 18, 2006 by sankar in Cisco General

1. Create a file by the name hideuser.ldif (can be any name) in Notepad

2. Lets take the example of hiding ac user for Attendant Console. Put the following contents in the file and save it.

dn: cn=ac, ou=users, o=cisco.com
changeType:modify
replace:Description
Description:CiscoPrivateUser

3. Go to command line and run the following command.

ldapmodify -h <server name> -p 8404 -D “cn=Directory
Manager,o=cisco.com” -w <DCDAdmin Password> -c -f hideuser.ldif

Gatekeeper – Viazone behaviour

Posted: September 11, 2006 by cciestudy in Cisco General, Gatekeeper

How to trigger via zone behaviour?

Local zones – always enable outvia on the destination zone

Remote zones – use invia or outvia on the remote zone

Via-zone gatekeepers differ from legacy gatekeepers in how LRQ and ARQ messages are used for call routing. Using via-zone gatekeepers will maintain normal clusters and functionality. Legacy gatekeepers examine incoming LRQs based on the called number, and more specifically the dialedDigits field in the destinationInfo portion of the LRQ. Via-zone gatekeepers look at the origination point of the LRQ before looking at the called number. If an LRQ comes from a gatekeeper listed in the via-zone gatekeeper’s remote zone configurations, the gatekeeper checks to see that the zone remote configuration contains an invia or outvia keyword. If the configuration contains these keywords, the gatekeeper uses the new via-zone behavior; if not, it uses legacy behavior.

For ARQ messages, the gatekeeper determines if an outvia keyword is configured on the destination zone. If the outvia keyword is configured, and the zone named with the outvia keyword is local to the gatekeeper, the call is directed to a Cisco Multiservice IP-to-IP Gateway in that zone by returning an ACF pointing to the Cisco Multiservice IP-to-IP Gateway. If the zone named with the outvia keyword is remote, the gatekeeper sends a location request to the outvia gatekeeper rather than the remote zone gatekeeper. The invia keyword is not used in processing the ARQ.

CCM Security – MGCP

Posted: September 7, 2006 by cciestudy in Cisco General, CM4.1 Features

crypto isakmp policy 1
encr 3des
authentication pre-share
group 2
lifetime 10800
crypto isakmp key cisco address 10.1.1.1
crypto isakmp key cisco address 10.1.1.2

!
!
crypto ipsec transform-set CM esp-3des esp-sha-hmac
mode transport
!
crypto map CM 1 ipsec-isakmp
set peer 10.1.1.1
set transform-set CM
match address 101
crypto map CM 2 ipsec-isakmp
set peer 10.1.1.2
set transform-set CM
match address 102

!
access-list 101 permit ip host 10.2.2.2 host 10.1.1.1

access-list 102 permit ip host 10.2.2.2 host 10.1.1.2
interface Serial0/0.101 point-to-point
ip address 10.2.2.2 255.255.255.0
frame-relay interface-dlci 101
crypto map CM

voice translation-rule 1
rule 1 /\(^[2-9]………$\)/ /91\1/ — for national calls
rule 2 /\(.*\)/ /9011\1/ — for international calls

!
!
voice translation-profile ANI
translate calling 1

a. setup meetme conference, conf bridge as necessary. Let meetme number be 1900

b. setup a route point for calls from external and internal callers as the dial-in bridge number. Let this be  1800. Cfwdall this CTI route point to voice mail.

c. Setup a Call handler meetme in Unity. Under transfer settings, tell it to ring subscriber at extn 1900. Use Supervise transfer and Check Ask Caller’s name option.

d. Create a call routing rule under forwarded calls in Unity, and set teh Forwarding station to be 1800 (CTIRP). Attempt a transfer to callhandler meetme that you just created in step c.

Unity will ask the caller his name and transfer him to the conference bridge. Conference bridge members who already have joined the conference will hear, “Call from <callername>”

Allow caller input – Unity

Posted: August 8, 2006 by sankar in Cisco General, Unity

Under caller input page, lock a key (0 through 9, * #) to a particular action if you want Unity to perform that action as soon as you press that key. The “Allow callers to dial an extension durin greeting” has no effect if the keys are locked. To allow callers to dial an extension during the greeting, dont lock the key to a particular action

 If you have any of your keys set to Ignore key, the greeting that is played is usually System greeting “I do not recognize that as a valid selection”. This is the Error greeting. Expose the Error greeting using Advanced Settings tool from Tools Depot and you can re-record the Error greeting to a message of your choice.