Archive for the ‘CM4.1 Features’ Category

CCM Security – MGCP

Posted: September 7, 2006 by cciestudy in Cisco General, CM4.1 Features

crypto isakmp policy 1
encr 3des
authentication pre-share
group 2
lifetime 10800
crypto isakmp key cisco address 10.1.1.1
crypto isakmp key cisco address 10.1.1.2

!
!
crypto ipsec transform-set CM esp-3des esp-sha-hmac
mode transport
!
crypto map CM 1 ipsec-isakmp
set peer 10.1.1.1
set transform-set CM
match address 101
crypto map CM 2 ipsec-isakmp
set peer 10.1.1.2
set transform-set CM
match address 102

!
access-list 101 permit ip host 10.2.2.2 host 10.1.1.1

access-list 102 permit ip host 10.2.2.2 host 10.1.1.2
interface Serial0/0.101 point-to-point
ip address 10.2.2.2 255.255.255.0
frame-relay interface-dlci 101
crypto map CM

Time of Day routing

Posted: August 2, 2006 by sankar in CM4.1 Features, ToD

Rule of thumb.

a. First analyze and group the time-period for which you want the partition to be active. This could be business hours (M-F, 8-5 for say).

b. If the time slots cannot be grouped into one time period, define multiple time periods.

c. Group all timeperiods into one time schedule.

d. apply time schedule to partitions and partitions to CSS.

e. calling devices should use this CSS (Gateways/ phones etc)

f. Note that when you want differential call treatment based on ToD, you need to create a tie on the dialed number. To create the tie, you have to define the same number (say 1005) twice  one in each partition P1 and P2. P1 may be a TOD enabled partition, while P2 may be a normal partition. P1 will be listed above P2 in the calling device CSS.

Callforward behaviour in 4.1

Posted: July 20, 2006 by cciestudy in CM4.1 Features

Callforward All

If the Call Forward all CSS is set to none, it will concatenate the line and device CSS. This applies to settings done via the phone as well as via the CCM user page.

Callforward Busy/No-answer 

If the Callforward CSS is set to none, it does not concatenate the line and device CSS.

Line Device CSS contatenation

Posted: July 19, 2006 by cciestudy in CM4.1 Features

In CCM 4.1, Callmanager concatenates the CSS of the device and lines and places the CSS of the lines in front of the CSS of the device.

As per SRND, For CTI ports and CTI Route points, it does the other way. ie, CSS of the device comes first followed by the CSS of the lines. This used to be the behaviour in CCM  3.1. This was not the case during testing. Even the CTI ports and CTI route points were using line CSS First

CMC and FAC

Posted: July 19, 2006 by sankar in CM4.1 Features

When you have a CMC and FAC enabled on a route pattern, you have to enter FAC first, before entering CMC code.

CMC codes do show up on CDR records (unlike FAC)

FAC and CDR

Posted: July 19, 2006 by sankar in CM4.1 Features

When you define FAC code names and auth codes, only FAC code names appear on CDR. (For added security). The auth codes themselves never show up.

Call Display restrictions

Posted: June 30, 2006 by cciestudy in CM4.1 Features

For internal calls, use translation patterns

Calling Line ID/Name Presentation: This is the Caller ID /Name that shows up at the destination phone while the phone is ringing and connected
Connected Line ID/Name Presentation: This is the Caller ID /Name that is displayed at the source phone while the destination phone is ringing and connected

To override the settings at the translation pattern, check the “Ignore Presentation Indicators (internal calls only)” at the phone. When this is enabled, it will override the Connected Line ID/Name at the source phone and Calling line ID/Name at the destination phone.

Interaction with Callpark

To enable restrictions on Call park numbers, you would need to define a transation pattern for each of the call park numbers. Say, if your Callpark is 400X, then you would need to add 10 translation patterns starting 4001, 4002.